Helpful ReplyTask Sequence hangs on Dell models with SSD

Author
EdwardKK
Expert Member
  • Total Posts : 190
  • Scores: 2
  • Reward points: 23650
  • Joined: 2007/05/14 14:42:18
  • Status: offline
2013/10/11 12:12:19 (permalink)
0

Task Sequence hangs on Dell models with SSD

Ok.  I'm posting this hoping someone has an insight that I'm missing.
 
Running SCCM 2012 rtm with MDT 2012 integrated.  I'm running a fairly basic MDT based Win7 64bit TS to load a thin WIM, and several apps (office, citrix, etc).  So, now I'm testing driver injection on various models.  I have driver packages setup for most of the Dell laptops models we have in production, and then I let the TS scan for drivers just in case we run up against a strange model that isn't standard but we might have a handful of these other models floating around someplace.  
 
So, I run my TS on a Dell E6530.  All works fine.. drivers load, TS loads great.  Then someone hands me an E6530 with an SSD installed (Samsung SM841 SSD, which is a 128GB drive).  I run the TS, and it runs through OS install and setup, driver injection, then it installs a couple packages (Adobe reader for example), then hangs during an application package install in the TS.  The app install where it hangs is a traditional package (not a cm12 app).  No errors, it just stops like it never completes.  After the app hangs long enough for it's install time limit to pass, the TS fails saying it was cancelled.   
 
So, I start digging around...thinking I must not be formatting the SSD right or something, and in tinkering I discover that if I do not install a video driver for the HD Graphics 4000 adapter, and just let windows install the generic VGA adapter, the TS completes just fine.  The screen is 800x600 resolution when we're done, but its complete.  So, that makes me think its NOT an SSD formatting issue, but a driver issue.  I pull new drivers from Intel (mine was pulled from Dell's SCCM Cabs, and turned out to be a few years old), but that didn't help.  
 
We're hanging on a Citrix offline plugin installation.  Does anyone have any idea why a video driver would create this problem?  As a workaround, I could put a video driver injection step at the end of the TS, and avoid the issue, but I'm hoping someone might have a clue what might be causing the issue.  I did check and based on Intel's scans, all my Intel driver codes are up to date.  (I had thought that maybe my Intel vid driver was conflicting with some other intel chipset driver or something weird).
 
Anyone have ideas on this?  
 
Thanks!
 
 
 
post edited by EdwardKK - 2013/10/11 12:35:25
#1
dhedges
Starting Member
  • Total Posts : 17
  • Scores: 4
  • Reward points: 38450
  • Joined: 2009/09/30 10:20:36
  • Location: Austin, TX
  • Status: offline
Re:Task Sequence hangs on Dell models with SSD 2013/10/11 21:56:15 (permalink) ☄ Helpful
0
 
The E6530's come with both an Intel and a Discrete graphics option (Nvidia).  If you have Optimus enabled in BIOS (default), then you need to install the Intel driver (setup.exe), reboot, then install the Nvidia driver (setup.exe).  I had hanging issues and issues with one or having the Nvidia driver load before the Intel and it causes all sorts of issues.

I suppose I should write up a blog post on this.  Check http://deploymentramblings.wordpress.com over the next week or so and I'll try and get something put together.
 
-Dustin
#2
EdwardKK
Expert Member
  • Total Posts : 190
  • Scores: 2
  • Reward points: 23650
  • Joined: 2007/05/14 14:42:18
  • Status: offline
Re:Task Sequence hangs on Dell models with SSD 2013/10/15 13:00:10 (permalink)
0
Hmm, that's curious.  I'll keep that in mind.  
I'm not having quite that problem.  But I'll try disabling the Optimus and see what that does.
 
What's happening for me is that when I install the Citrix offline client, it also inserts the MS VHD HBA device/driver.   And that's where it appears to be hanging.  
 
BUT, it only hangs on that install when I have the Intell HD 4000 driver installed, AND if the machine is an SSD.  If I don't install the Intel driver, and run with a generic video driver, no hang.  If I install all the drivers but don't have an SSD, no hang.  And, here's the real annoying part... If I install the drivers with an SSD during a TS, and wait to install the Citrix offline client AFTER the TS is completed (say from Software Center), it installs without a problem.  
 
..must...control... fist of death....  
 
 
 
 
#3
EdwardKK
Expert Member
  • Total Posts : 190
  • Scores: 2
  • Reward points: 23650
  • Joined: 2007/05/14 14:42:18
  • Status: offline
Re:Task Sequence hangs on Dell models with SSD 2013/10/16 10:47:10 (permalink)
0
hmmm, very curious.  You nailed it with the Optimus settings.  Optimus, which allows the hardware to dynamically swap video cards, seems to be involved in this problem.  So, I created a CCTK package that disables optimus in the BIOS at the start of the TS, and then I can reenable it at the end after everything installs and loads. 
 
Now, WHY the video settings and drivers would impact the installation of other devices is a bit of a mystery, but it's not one that I'm going to chase down as it's probably too deep in the bowels of Win7/Hardware interaction for me to care.  
 
Thanks!
#4
Jump to:
© 2018 APG vNext Commercial Version 5.5